Password instructions will be e-mailed to you
Confirmation will be e-mailed to you
Lost Password
Register
Dismiss
Dismiss

Lost Format on Blog Post

Home Forums Creating A Vacation Rental Website Lost Format on Blog Post

This topic contains 11 replies, has 6 voices, and was last updated by  sherene@mystarvr.com 9 months ago.

  • Author
    Posts
  • #5879

    Lost my formatting on my blog post when I was adding a new post. I removed the post and that didnt help. Not sure what I did but even when I go back to restore it even from the original version, it wont go back to the little squares. It is just large post running down the page one after the other. How do I fix this?

  • #5880

    Terry Whyte
    Participant

    I would delete the plug in and reinstall it.

  • #5883

    I deactivated both Elementor Anywhere and Vacation Soup plugins that I installed and then reactivated and its still the same.

  • #5885

    alan egan
    Keymaster

    Hello Lynn, I too have been having problems with Postgrid.

    I’m looking for a solution. I am using a paid plugin on the learning centre. It’s called posts carousel pro – https://shapedplugin.com/plugin/post-carousel-pro/

    It costs $39 It’s very good

    There are quite a few other options in the WordPress repository – Try searching for the term Masonry

     

  • #6034

    amantalv@nc.rr.com
    Participant

    Hey all.

    I saw someone else earlier post that they lost their pictures when they published a new post.  I too have this problem now.  I too unpublished the new post and it still won’t show the picture from the first post on the destination page.  I went out and installed the Simple Masonry plug in.  It adds new options and there was some shortcode you could copy to the page.  I tried that.  It clocked for a while and never did anything when I updated.  Scratching my head and not sure what all could be broken by simply updating with a new post.

    I thought perhaps it was the size of the pictures battling for contention on the site, but I removed the pictures too and even tried smaller ones.  That didn’t do it either.

    Any epiphanies or eureka moments?

    Thanks,

    Aris

  • #6043

    alan egan
    Keymaster

    Please try this

    Create a new page called blog, publish it. Go to settings, reading and make the blog page option to blog (the page you just created)then click save. Hopefully that should fix it

  • #6092

    amantalv@nc.rr.com
    Participant

    OK,

    So I updated as per the above instruction.  When I saved, there was no difference in behavior.  I then decided to try to go to >settings>reading

    and where it says Posts Page, I selected the “our destination page” instead of the “blog” page and saved that.  From the homepage of the live site, I went to the Our Guide Page, which contains the posts, and now I am able to see both posts I have published, but they are published with the newest on top of the oldest.  The page displays both posts in succession.  I went back into >settings>reading and where it says “blog pages to show at most” I changed that from 10 to 1.  Saved that.  Now when you go to the Our Guide Page, it shows the most recent post on one page, and you have to go to page 2 to see the 2nd post.  This isn’t horrible, but I rather liked the grid format as was original.  Has anyone progressed on this?

    Here’s what it looks like now:  https://mvillaobx.com/our-destination-guide/

    Thanks,

    Aris

  • #6095

    susant
    Participant

    Hi,

    I think by changing your reading settings you’ve stopped the plugin working so you don’t have a grid anymore and are just seeing your posts the default way, with one per page as you have selected 1.

    If you want to try another grid plugin I’ve not had problems with the free one called Content Views (https://wordpress.org/plugins/content-views-query-and-display-post-page/)

    Once installed create a view using the setting Grid layout, 2 items per row and paste the shortcode onto your blog page.

    In settings -> reading settings, I don’t have a page selected for posts page (-select-)

    And blog pages to show at most 10 (or however many you want per page)

    I didn’t like the green “read more’ and pagination buttons but you can change these (for free if you add some css code or pay for the pro plugin).

    Hope this helps, or at least gives you another option if you don’t have any success with the Postgrid plugin.

    • This reply was modified 9 months, 1 week ago by  susant.
  • #6097

    amantalv@nc.rr.com
    Participant

    Thanks Susan.  I went back and started playing with it some more.  I changed back what I had done and just went ahead and added the PostGrid shortcode to the actual Our Guide Page, instead of each individual post page, as I had done before.  That did the trick.  Looks good now.

    Thanks,

    Aris

  • #6098

    Hi Susan, I just downloaded “Content Views” but am very tech illiterate…. Do I have to paste that shortcode onto every blog post? adding to Our local guide page doesn’t seem to do anything.

    (I somehow have 2 different “Our local guide” pages and when I downloaded The Content Views plugin – it is showing me 3 views created by Alan Eagan in 2016….? I’m so confused….)

    Thanks, Sherene

  • #6101

    susant
    Participant

    Hi,

    The shortcode doesn’t go into each blog post, just the page which will show your blog grid. Mines just called “blog’ but yours may well be called “our local guide’.  Not sure why you have two. I’d delete one and make sure your menu (appearance -> menus has the one that is left in it).  That is the page which needs your short code (and not much else apart from a sentence or so saying “I hope you enjoy these updates with local news and things of interest” or something similar, and then the shortcode).

    And you only need one view in Content view although there is no harm in having three, the only one that will be relevant is the one whose shortcode you use. It needs the grid layout (click on it and look at ‘display settings’).

    If you find that the code isn’t doing anything I think it may be because your Reading settings are wrong. From Dashboard, Settings, Reading, don’t have a page selected for posts page, just have “-select-“.

     

     

  • #6116

    Thanks so much Susan! I think I am on the right track now. Whew….

     

You must be logged in to reply to this topic.