Password instructions will be e-mailed to you
Confirmation will be e-mailed to you
Lost Password
Register
Dismiss
Dismiss

problem soup stock to wordpress

Home Forums Creating A Vacation Rental Website problem soup stock to wordpress

This topic contains 37 replies, has 12 voices, and was last updated by  alan egan 7 months, 2 weeks ago.

  • Author
    Posts
  • #5148

    I’m in module 2, have organized hosting, got URL and downloaded WordPress. Now having a problem adding the plugin “soup-stock-release” which Safari tells me: “operation could not be completed, is a directory (NSPOSIX error domain 21). The file I downloaded was a different name to the one in the demo video which said “soup stock master” .  what should I do?

  • #5149

    I’m still stuck trying to add the vacation soup website to my new wordpress site. It clearly says on the add plugin page that the download should be a zip file. the file “soup stock release” does not appear to be a zip file?   What am I doing wrong?

  • #5150

    Anonymous

    Hi Don,

    I understand the error you have been getting is “Parse Error…in SoupStock.php on line 31”.

    This error occurs on some old unsupported versions of PHP. It would appear that you are running on a version of PHP that is earlier than 5.4, which is the minimum supported for Vacation Soup. I recommend you contact your hosting provider to ask them to upgrade the version of PHP.

    As a bit of background to help you, PHP officially stopped supporting 5.3 in 2014 evidenced here, we support 5.4 onwards, and WordPress recommends version 7 (the current version).

    Please can you confirm if this solves the problem for you?

    Francis

    • #5152

      [Now responding with my proper account!]

      I have updated the source code for the next release so that it provides a more informative error message. Thank you for reporting it.

      F

  • #5156

    Francis,

    Thank you for the advise. I have been on to my hosting co and updated the PHP to 5.6 (the highest value on my account without spending more money). Now I am advised to wait an hour for the change to be active.  If you don’t get another message then you can assume I am over that hurdle. Thanks.

    Don

  • #5157

    alan egan
    Keymaster

    Hi Don,

    Alan here, thanks for the update. I hope all goes well. Please let us know if you have any other problems.

  • #5158

    Francis,

    Now I again tried copying the latest vacation soup download as a plugin onto WordPress and this time I get a message that download failed as my domain MUST have SSL cert.   So back to web server, purchase and have to wait for the process to update.

    • #5160

      Hi Don,

      Google now downgrades sites that are not SSL certified, and with my background in security I want to make sure every Vacation Soup offering is safe, from a security standpoint. Using supported versions of PHP and forcing SSL are now considered a minimum for you to create a safe website.

      Version 5.6 is supported (security updates) until the end of 2018. By then your hosting provider should provide a free upgrade to a supported version, or you need a new hosting provider!

      I hope this helps.

      F

  • #5162

    Hi I believe I am having the same problem

    I down load the stock file folder. Then when I go to install the word press plug in and search the downloaded files a zip does not exist.

    Please advise.

     

    Thanks you

    Jim

  • #5163

  • #5164

    Never mind I figured I out. Had to download a zip program, zip the folders above that I downloaded then saved the zipped file to my desk top then uploaded the zip file.

     

     

    • #5167

      Hi Jim,

      The link we provide should simply download the zipfile, ready for you to install it. Unfortunately it appears your browser downloaded it, and then unzipped it automatically (unless you double clicked on the file, which can cause it to be unzipped). Could you please tell me what browser you are using, and are you on Windows or a Mac?

      We would much prefer to use the normal WordPress plugin download mechanism, however they do not approve of pre-built site installers, so there are some hoops to jump around.

  • #5170

    Helen@Chamoissiere
    Participant

    I am also having the error failed to open file:/tmp/stok.sql.

     

    PHP is version 7 and site has an SSL certificate.

     

     

    • #5171

      Hi Helen (apologies if Alan has advised me wrongly of your name 🙂

      I am sorry to hear that you are having problems, but i am sure we can get you through this bit. Unfortunately this is the first time we have seen this fault.

      Would it be possible to grant me access to your siteGround login, and I can diagnose the problem faster? If so, I recommend that you change your password temporarily. Would this be possible?

      Thanks in advance,

      F

  • #5175

    Helen@Chamoissiere
    Participant

    Hi Francis, my site is hosted with WHUK, as the domain was already registered and paid for on there. Happy for you to take a look if you wish to.

    Helen

     

     

  • #5176

    Helen@Chamoissiere
    Participant

    Do you need my cpanel log in?

     

    • #5177

      Yes please Helen. If you click on my image, the next page has a personal message link at the top. As it is a different hosting provider I have an idea what it might be and I should be able to get around it.

      F

  • #5178

    Helen@Chamoissiere
    Participant

    Message on the way Francis, many thanks.

    H

    • #5290

      bmaurits@yahoo.com
      Participant

      Have the same problem as Helen and Don.

      Installed the plugin on a blank, brand new WP install and activated it on https://www.amsport.nl/vacationrental and got this error message back: failed to open file:/tmp/stock.sql

      Cannot get back to the wp-admin screen, because of this error message coming up. Renamed the plugin name, and now I can get on the admin part

      What can it be? Did you solve this problem for Helen and Don?

      Regards

      Bou

      • #5305

        alan egan
        Keymaster

        Hello Bou,

        The problem for Don was an out of data version of php with his hosting company.

        Is everything working for you now?

  • #5179

    Dear Readers

    As of this post, while nearly all users installed the Stock with no issues, Helen & Don did require assistance. Their problems were caused by differences in their Hosted Service, and this required some handholding by our team to get the stock installed.

    We recommend SiteGround mainly because the combination of our packages and their service suits non-technical VR owners. As a result of these recent issues I must also add we recommend SiteGround because the install works smoothly. Being totally open I should add we also recommend them because we are an affiliate, and get a small commission.

    We will be publishing appropriate notices, but while we are launching several products, not least the main VacationSoup, we will not have the resources to support the enormous number of hosting services out there. If you have a need to install the Stock anywhere other than SiteGround, please bear this in mind and get professional support for the install as we will not be able to help as much.

    Note this only affects the installer, not the Stock or Soup itself, so once you’re up and running, even on a ‘foreign’ host, you will all be equal.

  • #5181

    Helen@Chamoissiere
    Participant

    Thank you for all of your help and persistence with the problem. I have installed WP on there on another occason without issue, so I did not expect to find any difficulties this time around, once I had got over the barrier of the SSL certificate.

     

  • #5182

    Remi Thackrey
    Participant

    For those of you that have a domain name registered with another company, as I did, it was well worth the one off fee of $14.95 to transfer the domain to SiteGround. Many companies charge for the extra services that SitGround include in the price. I did it myself using the online forms. While the explanation may seem complicated, for me it was very simple. I just got a code from my old hosting service by filling in a form and gave that to Siteground.

    Here is the link explaining how to do it. https://www.siteground.com/tutorials/getting-started/transfer-domains-to-siteground/

    It took a few days to complete the transfer, but this gave me a bit more time to prepare my pictures and videos.

    • This reply was modified 8 months, 3 weeks ago by  Remi Thackrey.
  • #5280

    berrysmiles@aol.com
    Participant

    I am having problems also  installing the plug in and get the message from Safari  telling me: “operation could not be completed, is a directory (NSPOSIX error domain 21). I am using Siteground, do they not have the version of PHP required

    Judy

     

     

  • #5289

    Hi Judy,

    This is a new one which I will have to investigate. It appears something went wrong in the early part of the installation, and this is probably a secondary error. We will need to ‘clean’ your current installation and re-install. If you would like I could take a look at it for you. I will contact you by email for further instructions.

    F

  • #5366

    Phoebe
    Participant

    I’m stuck with the SSL certificate issue as well and can’t install the plug in without it but I’m using a temporary URL and Siteground have informed me that I can’t have https with a temporary url only http so I’m stuck!  I’m using a temporary URL because I’m not sure what name to use in the end as I already have a reasonably high ranking site with a domain name I probably want to continue using but the site is made on joomla and Alan advised me to set up on a temporary name before trying to move the joomla site across – am I making any sense?  I’d appreciate any advice, thanks!

  • #5368

    Clare Cambridge
    Participant

    I’m also stuck, I posted a new thread as I didn’t realise this was the same problem,  when I paid for my wordpress site from site ground there wasn’t an option for SSL, so I don’t know if that’s the reason.  It wouldn’t upload the soup.  Message that came up is

    Unpacking the package…

    Installing the plugin…

    Destination folder already exists. /home/buryhill/public_html/wp-content/plugins/soup-stock-release/

    Plugin installation failed.

    Return to Plugin Installer

    I’ve tried a couple of times and keep getting the same message.  I’ve seen in other post there a mention of the php, I have no idea what this is, so it my problem has anything to do with that, I would need a bit of extra help please.

    Thanks

  • #5377

    alan egan
    Keymaster

    Hello Clare,

    Can you let Francis have your Siteground login details and he will sort this out for you.

    His mail is francis@vacationsoup.com

  • #5378

    Phoebe
    Participant

    Hi Alan or Francis, is anyone able to help me (comment above Clare’s comment which has had a response).  I’m totally stuck!  Thanks in advance.

    • #5385

      I am sorry Phoebe, I thought I had responded to you.

      We were unaware of the lack of SSL support for temporary URLs, that is a problem. The best option is for me to manually install the Stock for you. Please can you message me your siteGround login details and I will do the install for you.

      F

    • #5391

      SOLVED Phoebe Thomas

      Hi Phoebe,

      Eventually, I have (I trust) solved your problem, and your Stock site is now installed and ready for you to use. Their temporary URL, not being SSL, caused some issues, but their excellent support helped in the end. If you have any more problems, please do contact me.

      F

  • #5386

    Phoebe
    Participant

    Thanks Francis, I sent you an email

    • #5392

      Phoebe
      Participant

      Thank you! Hugely appreciated.

  • #5388

    Clare Cambridge
    Participant

    Hi Francis,  I have emailed you, as Alan suggested, but I haven’t received a reply.  My login details are in the email, I’m hoping you can sort it out soon too.   Also just want to add, when I paid for site ground, on my extra’s there wasn’t an option for the SSL certificate, is that some I need to worry about.  (I’ve read some of the other comments)  I wouldn’t know how to add it now, so if I need it could you direct me to the right place please.  Clare

    • #5390

      SOLVED clarecambridge

      Hi Clare,

      I have manually installed the stock and all should now be OK. Please contact me if you have any further problems.

      F

  • #5389

    Hi Claire,

    Just to confirm, I am on it, have your email, and will be in touch shortly.

    F

  • #5414

    Susan
    Participant

    I am having the same problem installing the plugin as Judy did.  The download did not appear as a zip file, and when I asked it to install, I got a message from Safari stating: “operation could not be completed, is a directory (NSPOSIX error domain 21). I am using Siteground.  I couldn’t see how Judy’s problem was resolved, can you help? Thanks, Susan

     

     

  • #5417

    alan egan
    Keymaster

    Hello Susan,

    Safari has a habit of unzipping downloads and this causes the problem that you are having.

    I’m sure that if you use Chrome you won’t have a problem.

    Please let me know if that solves the issue (fingers crossed)

You must be logged in to reply to this topic.